Interface SlackEndpointBuilderFactory.SlackBuilders

    • Method Detail

      • slack

        default SlackEndpointBuilderFactory.SlackEndpointBuilder slack​(String path)
        Slack (camel-slack) Send and receive messages to/from Slack. Category: social Since: 2.16 Maven coordinates: org.apache.camel:camel-slack Syntax: slack:channel Path parameter: channel (required) The channel name (syntax #name) or slack user (syntax userName) to send a message directly to an user.
        Parameters:
        path - channel
        Returns:
        the dsl builder
      • slack

        default SlackEndpointBuilderFactory.SlackEndpointBuilder slack​(String componentName,
                                                                       String path)
        Slack (camel-slack) Send and receive messages to/from Slack. Category: social Since: 2.16 Maven coordinates: org.apache.camel:camel-slack Syntax: slack:channel Path parameter: channel (required) The channel name (syntax #name) or slack user (syntax userName) to send a message directly to an user.
        Parameters:
        componentName - to use a custom component name for the endpoint instead of the default name
        path - channel
        Returns:
        the dsl builder